Wij hebben zon!

wijwillenzonners helpen elkaar

Welkom, Gasten
Gebruikersnaam: Wachtwoord: Onthoud mij
  • Pagina:
  • 1
  • 2

Onderwerp: Arduino spontaan niet te benaderen

Arduino spontaan niet te benaderen 11 maanden 4 weken geleden #11358

  • master64nl
  • master64nl's Profielfoto
  • Afwezig
  • Platina
  • Na regen komt zonneschijn
  • Berichten: 711
  • Ontvangen bedankjes 5
Ik heb een Arduino met het programma Solarmeter al enige jaren lekker draaien. Omdat ik een paar keer per jaar mijn printje dat de ledpulsen telt (van de brutoproductiemeter) moest afregelen heb ik besloten om een kWH meter met SO puls te kopen. Deze aangesloten en dit werkte prima. Netjes werden de pulsen doorgegeven en via de Arduino weer aan PVOutput. Lekker dacht ik nog, niet meer klooien met dat afregelen. Er was nog een klein probleempje namelijk dat er via het tweelinsnoertje er af en toe een puls je gegenereerd werd waardoor hij bleef door tellen met af en toe 2 watt wanneer er geen pulsen meer van de kWH af kwam. Dit ging door tot de volgende dag todat er weer genoeg licht was waardoor de kWH meter zijn SO pulsen ging geven. Hier moest ik nog een afgeschermd snoertje voor halen.
Een hele inleiding maar misschien heeft het er iets mee te maken. Vanaf gisteren 14:45 stopte de Arduino er plotseling mee. Een paar keer aan en uit gezet maar geen effect. Ik kan de Arduino wel pingen op zijn IP adres maar ik kan hem niet meer zien via de webbrowser en hij geeft daardoor geen gegevens meer aan PVOutput. Ook zie ik bij de status van de modem-router dat het IP adres van de Arduino contact heeft. Heel vreemd.

Wat heb ik gedaan tot nu toe:
Ping naar IP adres Arduino is goed.
IP Arduino is te zien in het statusoverzicht van de modem-router.
Terug gegaan naar Solarmeter 11.41 maar geen effect.
Opnieuw flashen met Solarmeter gaat goed zonder fouten maar heeft geen effect.
Draadje los gehaald van de SO puls maar geen effect.

Mijn kennis komt niet verder dan hier. Wie kan mij helpen om te achterhalen wat er fout/stuk is?
Laatst bewerkt: 11 maanden 4 weken geleden door master64nl.
Alleen ingelogde leden kunnen reageren.

Arduino spontaan niet te benaderen 11 maanden 4 weken geleden #11359

  • master64nl
  • master64nl's Profielfoto
  • Afwezig
  • Platina
  • Na regen komt zonneschijn
  • Berichten: 711
  • Ontvangen bedankjes 5
Gevonden!

Ik kwam er achter doordat hij het even kort had gedaan naar PVOutput toen ik hem voedde via usb met mijn laptop om opnieuw te flashen. Dus ik haal hem uit de meterkast en maak hem open. Direct draadjes los :( dus moest ik weer solderen, je kent het wel. Meteen een afgeschermde getwist utp kabel gebruikt voor de pulsteller want dat zou beter moeten zijn. Ik sluit alles weer aan en sluit hem binnen even via de laptop aan en hij doet het :cheer: . Dus ik maak hem dicht en probeer het nog eens voor de zekerheid en hij doet het. Ik bouw hem in de meterkast en dan doet hij het niet :huh: . Weer terug naar de woonkamer en daar doet hij het :huh: . Doe hem weer in de meterkast en weer niet werken :( . Ik bedoel daar mee wel ledjes aan maar geen verbinding met de webbrowser. Ik check nog ethernet kabels maar dan maakt ook geen verschil. Weer alles naar binnen en wederom werken. ik word gek :pinch: .Toen sloot ik hem op de voeding aan dus niet via de usb en toen werkte hij niet meer. Weer terug op usb en ja dan wel. AHA B) het is dus de voeding. Nieuwe voeding gepakt van 6Volt2Amp en dan doet hij het weer niet in de meterkast. Toen een telefoon usblader gepakt en daar de usb in gedaan en dan doet hij het wel. WTF :silly:
Pffffffffff conclusie: Er is iets defect op de Arduino waar de voedingsplug zit. Ik had nog geprobeerd de draden direct op de print te solderen maar ook dat maakt niets uit. Hij doet het wel dus via de usb ingang maar niet via het circuit waar de voedingsplug in gaat. Wat vreemd allemaal hé :side:
Laatst bewerkt: 11 maanden 4 weken geleden door master64nl.
Alleen ingelogde leden kunnen reageren.

Arduino spontaan niet te benaderen 11 maanden 4 weken geleden #11360

  • Ton_vanN
  • Ton_vanN's Profielfoto
  • Aanwezig
  • Moderator
  • Berichten: 867
  • Ontvangen bedankjes 56
Zoals je het beschrijft, riekt dit naar een defect in het voedingsconnector of het voedingscircuit op de Arduino-print.
Als je naar het bijgevoegde schema kijkt (van een UNO rev3, dus even oppassen als je een andere versie hebt!), dan zit voedingsconnecter X1 met het voedingscircuit rechtsboven, en de USB-interface X2 aan de linkerkant.
Grote stappen, snel thuis: zie je een groene LED aangaan als je de aparte voeding gebruikt?
Dat zou de LED kunnen zijn die rechtsboven is getekend, en dan is er dus wel spanning aan de uitgang van IC U1, maar heb je een andere probleem ..........
Dat stuk voedingscircuit gebruikt een aantal componenten (w.o. genoemd IC U1) voordat de voeding echt op de print komt.
Als die LED niet aangaat, en je kunt D1 en PC1 vinden, dan kun je meten of de ingang naar het IC U1 goed is.

Bij gebruik van de USB-interface kom je vanaf connector X2, contact 1 via een andere weg via het circuit linksboven tot een +5V voeding op de print.
Bijlagen:
Uitdaging = met minimale kosten meer zon vangen
Laatst bewerkt: 11 maanden 4 weken geleden door Ton_vanN.
Alleen ingelogde leden kunnen reageren.

Arduino spontaan niet te benaderen 11 maanden 4 weken geleden #11361

  • master64nl
  • master64nl's Profielfoto
  • Afwezig
  • Platina
  • Na regen komt zonneschijn
  • Berichten: 711
  • Ontvangen bedankjes 5
Hi Ton, bedankt voor je schema maar ik heb een Mega en de geuploade foto is slecht te lezen. Deze is van toepassing:

Bijlage:

Bestandsnaam: arduino-mega2560_R3-sch.pdf
Bestandsgrootte: 47 KB
Laatst bewerkt: 11 maanden 4 weken geleden door master64nl.
Alleen ingelogde leden kunnen reageren.

Arduino spontaan niet te benaderen 11 maanden 4 weken geleden #11362

  • master64nl
  • master64nl's Profielfoto
  • Afwezig
  • Platina
  • Na regen komt zonneschijn
  • Berichten: 711
  • Ontvangen bedankjes 5
Dit circuitje.
VoedingsingangArduinoMega.jpg
Alleen ingelogde leden kunnen reageren.

Arduino spontaan niet te benaderen 11 maanden 3 weken geleden #11363

  • Ton_vanN
  • Ton_vanN's Profielfoto
  • Aanwezig
  • Moderator
  • Berichten: 867
  • Ontvangen bedankjes 56
;-) Begrijp je opmerking over slechte leesbaarheid: het wordt een beetje beter als je de file download en lokaal bekijkt met een viewer.

Het circuitje dat jij uit het MEGA-schema hebt gehaald, is nagenoeg gelijk aan dat van UNO-R3 (alleen C2 is verschoven), met zelfs gelijke benamingen voor de componenten.
Uitdaging = met minimale kosten meer zon vangen
Laatst bewerkt: 11 maanden 3 weken geleden door Ton_vanN.
Alleen ingelogde leden kunnen reageren.
  • Pagina:
  • 1
  • 2
Tijd voor maken pagina: 0.090 seconden